pixilang 2.0 and win7 64bit

Pixilang programming language
Post Reply
User avatar
spiny
Posts: 46
Joined: Mon Jul 19, 2010 4:28 pm

pixilang 2.0 and win7 64bit

Post by spiny » Sat Jul 23, 2011 4:38 pm

Hi guys,
are there any issues with pixilang and win7 64bit ?

I've got back into pixi coding after a year or so break and i now have a newer computer :) the code i've done runs fine on xp but runs very slowly on win7.

when i start the pixilang exe, the 'byte code generation' bit now takes 30-40 seconds and when the program is running some functions make the program stall for 5 or so seconds, specifically routines like this:

music8:
nowplaying = 8
progress = 165
fadeseed=35
stoptunes
load_music ("finalmusic/08-Rhino-Next.xm",8)
vol = 0
music_volume( vol )
play_music (8)
keypress=0
ret

i have a few different tunes that can be changed with a keypress, for example, pressing '8' calls the above routine, but it seems to hang for a while on the load_music part.

I have semi-replicated this by trying a 'pre load' of all the tunes, and they take just as long to load if i put the load_music at the start of the program as they do if i call each one when i want to change the tune.

the only difference other than win7 is that I have a lot of network shares on this machine, and i've noticed that 'pixifiles2.dat' seems to be doing something with visible drive letters, is it anything to do with this ?

cheers, phil :)

User avatar
spiny
Posts: 46
Joined: Mon Jul 19, 2010 4:28 pm

Re: pixilang 2.0 and win7 64bit

Post by spiny » Mon Jul 25, 2011 6:20 pm

Nightradio suggested dropping back to v1.6 and that did the trick :)

back to coding now .. :)

Post Reply