Playback speed is different between Windows Mobile and Win32

Post Reply
organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Playback speed is different between Windows Mobile and Win32

Post by organic io » Wed Dec 05, 2012 8:39 am

OK so I have been working on a song. I recorded a live drum part while listening to the Windows Mobile version of the song. When I rendered all the parts out and took it to Reaper, the live drums part drifts out of sync with the rest of the song.

I double checked and listened to the exported wavs versus the Windows mobile song playback, they drift.. After about 2 minutes of playing, they are about 4 seconds apart.

At this point I'm going to have to either figure out how to timestretch my drumming, or re-record. Re-recording isn't optimal because I did it in the church sanctuary where I can get natural reverb. :)

User avatar
NightRadio
Site Admin
Posts: 3157
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by NightRadio » Wed Dec 05, 2012 8:50 am

I recorded a live drum part while listening to the Windows Mobile version of the song.
Recorded in Reaper?

organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by organic io » Wed Dec 05, 2012 9:16 am

NightRadio wrote:
I recorded a live drum part while listening to the Windows Mobile version of the song.
Recorded in Reaper?
No, recorded on a Zoom H1 digital recorder which I hope has accurate timing :)
Plus remember that the output renders from Win32 Sunvox export drifted compared to the playback of the Windows Mobile during a side-by-side comparison.

Anyway I figured out how to timestretch in Reaper, but it didn't work at first because openbox was stealing the alt key when I tried to alt-drag the take. I had to edit an xml file to disable this behavior. It took me a while but it is always worth it for the music :D

organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by organic io » Wed Dec 05, 2012 9:20 am

P.S... The playback rate on both my timestretched drum takes is 0.995, I don't know if that will help you figure out the offset ?

User avatar
NightRadio
Site Admin
Posts: 3157
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by NightRadio » Wed Dec 05, 2012 4:23 pm

You recorded drum part on Zoom H1 while listening some another part on Windows Mobile SunVox.
Then exported SunVox part to the WAV too.
Then mixed both drums.wav (from Zoom H1) and sunvox.wav (from SunVox) in Reaper. And they play out of sync.
I described it right?

organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by organic io » Wed Dec 05, 2012 6:54 pm

NightRadio wrote:You recorded drum part on Zoom H1 while listening some another part on Windows Mobile SunVox.
Then exported SunVox part to the WAV too.
Then mixed both drums.wav (from Zoom H1) and sunvox.wav (from SunVox) in Reaper. And they play out of sync.
I described it right?
Yes.

User avatar
NightRadio
Site Admin
Posts: 3157
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by NightRadio » Wed Dec 05, 2012 11:14 pm

The first assumption - may be Audio playback has a bit detuned frequency on your Windows Mobile device?
You can check it easily: try to play one SunVox song on Windows Mobile and Win32 simultaneously. Or record the sound from Win Mobile using Zoom H1 and then compare this sound with the WAV exported from SunVox.

organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by organic io » Thu Dec 06, 2012 1:19 am

NightRadio wrote:The first assumption - may be Audio playback has a bit detuned frequency on your Windows Mobile device?
You can check it easily: try to play one SunVox song on Windows Mobile and Win32 simultaneously. Or record the sound from Win Mobile using Zoom H1 and then compare this sound with the WAV exported from SunVox.
OK, I'll do some testing. that's probably what it is. I don't know why I expected it to be the same. But timestretching did the trick so it's not a terrible loss

organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by organic io » Thu Dec 06, 2012 1:19 am


User avatar
NightRadio
Site Admin
Posts: 3157
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by NightRadio » Thu Dec 06, 2012 8:27 am

Nice song!

organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Re: Playback speed is different between Windows Mobile and W

Post by organic io » Thu Dec 06, 2012 6:25 pm

NightRadio wrote:Nice song!
Thanks :D


P.S.. I might have another bug report with a previous version of the .sunvox file of it, I'll report back later :)

Post Reply