Page 1 of 1

Linux Startup

Posted: Sun Mar 25, 2018 5:15 am
by Bunchy
Hi

I'm having trouble starting the ANS program in Linux. Clicking START_LINUX_X86_64
brings me to a text editor and shows the following below at bottom of this message. I've also tried to start it through the terminal with sudo START_LINUX_X86_64.....and nothing happens either.

Is there something i'm missing? Thank You for your help
Marc


#!/bin/bash

SOURCE="${BASH_SOURCE[0]}"
while [ -h "$SOURCE" ]; do # resolve $SOURCE until the file is no longer a symlink
DIR="$( cd -P "$( dirname "$SOURCE" )" && pwd )"
SOURCE="$(readlink "$SOURCE")"
[[ $SOURCE != /* ]] && SOURCE="$DIR/$SOURCE" # if $SOURCE was a relative symlink, we need to resolve it relative to the path where the symlink file was located
done
DIR="$( cd -P "$( dirname "$SOURCE" )" && pwd )"

cd $DIR
./bin/pixilang_linux_x86_64 boot.pixicode

Re: Linux Startup

Posted: Sun Mar 25, 2018 12:03 pm
by NightRadio
I'm having trouble starting the ANS program in Linux. Clicking START_LINUX_X86_64
brings me to a text editor and shows the following below at bottom of this message.
It's a problem of some graphics file managers. For example, in Nautilus: https://askubuntu.com/questions/286621/ ... n-nautilus
Execution of scripts is disabled by default.

I've also tried to start it through the terminal with sudo START_LINUX_X86_64.....and nothing happens either.
Nothing at all? No any error/warning messages?

Re: Linux Startup

Posted: Sun Mar 25, 2018 10:17 pm
by Koekepan
I just open an xterm, cd to the directory in question, and then do:

./START_LINUX_X86_64

Works fine then.

Re: Linux Startup

Posted: Mon Mar 26, 2018 7:47 am
by Bunchy
Of Course!! It now works. Thank You NightRadio
Using file manager "Files"


NightRadio wrote:
Sun Mar 25, 2018 12:03 pm
I'm having trouble starting the ANS program in Linux. Clicking START_LINUX_X86_64
brings me to a text editor and shows the following below at bottom of this message.
It's a problem of some graphics file managers. For example, in Nautilus: https://askubuntu.com/questions/286621/ ... n-nautilus
Execution of scripts is disabled by default.

I've also tried to start it through the terminal with sudo START_LINUX_X86_64.....and nothing happens either.
Nothing at all? No any error/warning messages?