Autostart SunVox issues

Multi-platform modular music creation studio
Post Reply
goobius
Posts: 2
Joined: Wed Oct 23, 2019 11:44 am

Autostart SunVox issues

Post by goobius » Wed Oct 23, 2019 11:55 am

Currently using Raspian Lite with SunVox installed. Runs perfectly via the softrender enabled.

My problem was when I try to start it with a .desktop script it boots but it is laggy as if softrender is never working.
Trying a few methods narrowed it down to being called to be opened via terminal that caused the lag.

Doing:

Code: Select all

/home/patch/sunvox/sunvox/linux_arm_armhf_raspberry_pi/./sunvox
Causes it to be laggy. So perhaps it's not the script and execution via terminal? Do i have permission issues here or something else?
I'm clueless.

User avatar
NightRadio
Site Admin
Posts: 3392
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Autostart SunVox issues

Post by NightRadio » Wed Oct 23, 2019 12:12 pm

What sunvox_config.ini do you use?
It depends on the current working directory.
When you launch SunVox from Terminal, it can find the config in the same folder with the executable.
But if you lanuch it from the desktop (or other graphics file manager) - current working dir may be different. In this case SunVox will use sunvox_config.ini from the ~/.config/SunVox

goobius
Posts: 2
Joined: Wed Oct 23, 2019 11:44 am

Re: Autostart SunVox issues

Post by goobius » Wed Oct 23, 2019 3:12 pm

It's been killing me for two days! Thank you, that fixed it.

(Also thank you for your help via email earlier)

Post Reply