Page 1 of 1

SunVox Lib 1.9.4c macOS: no sound output for xm/mod playback

Posted: Tue Aug 07, 2018 12:23 pm
by foma
Hi,
Loading up .mod and .xm files outputs silence (even though files are confirmed to be loaded and be playing by library).
Converting these to .sunvox and playing them makes sound work. Playback in SunVox app is unaffected, too.
Attached an example .xm file that doesn't give sound (they all don't) and converted .sunvox one that does.

This is not an issue on Windows – mod/xm do output sound there.

Reproduced on macOS 10.13.2 and 10.13.6 using SunVox-Unity wrapper

Thank you for your outstanding work,
Cheers!

Re: SunVox Lib 1.9.4c macOS: no sound output for xm/mod playback

Posted: Fri Aug 10, 2018 12:43 pm
by NightRadio
Have you read this instruction?: viewtopic.php?f=3&t=4399
I think this is the reason

Re: SunVox Lib 1.9.4c macOS: no sound output for xm/mod playback

Posted: Fri Aug 10, 2018 6:48 pm
by foma
It doesn't seem to be the reason, as files converted to .sunvox (see attachment #2) do output sound fine. Also I can read note/controller value info from mod/xm and library sure is playing notes, there's just no sound output.
Very same code works on Windows with sound.

Re: SunVox Lib 1.9.4c macOS: no sound output for xm/mod playback

Posted: Fri Aug 10, 2018 9:26 pm
by NightRadio
That's my fault, sorry. I missed the "Lib" word in the subject :)
It's a bug in iOS/macOS version of the library. Will be fixed soon.

Re: SunVox Lib 1.9.4c macOS: no sound output for xm/mod playback

Posted: Sun Aug 12, 2018 2:51 pm
by NightRadio
Please try the latest version of the library:
v1.9.4c macOS/iOS update (12 aug 2018)

Re: SunVox Lib 1.9.4c macOS: no sound output for xm/mod playback

Posted: Tue Aug 14, 2018 1:12 am
by foma
Yes, it works!
Thank you!