Modules are being moved automatically !? [FIXED in v1.7.3]

Found a bug? Post it here.
Post Reply
organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Modules are being moved automatically !? [FIXED in v1.7.3]

Post by organic io » Fri Nov 16, 2012 8:23 pm

Hey Nightradio. Weird bug I discovered yesterday. I loaded up a song I was working on, and some of the modules had moved positions. Every time I moved them back, saved, and reloaded the song, they would be in the wrong place again! This was on ARM version, but I also tested it on Win32 and it does the same thing.

The sunvox file is here:
http://www.loopproject.com/filebase/sdc ... ce-bug.rar

The offending modules that keep getting relocated are: 2A (multisynth called "clap"), 54 (also a multisynth called "clap"), they are "supposed" to be up above the clap samplers - 3F, 29, 55, 56
Also module 50 (generator called "saw") keeps getting moved towards the center, and is supposed to be down below between multisynth 4D and distortion 4F

It seems like for some reason it wants to place them inside the viewable area of the modules view/sound network when Sunvox is launched, which throws them really far out of place since they are supposed to be so far away from the center.

Weird huh?

Hope this bug report helps. It's not a critical error though. Yesterday I had an idea how to reorganize my modules differently in the future anyway, so I'll be trying that on my next song. :D

User avatar
NightRadio
Site Admin
Posts: 3352
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Bug - Modules are being moved automatically !?

Post by NightRadio » Sat Nov 17, 2012 11:03 am

Fixed. Will be in the near update.

organic io
Posts: 439
Joined: Fri Jun 24, 2011 12:31 am
Location: USA - North Carolina
Contact:

Re: Modules are being moved automatically !? [FIXED in v1.7.

Post by organic io » Sun Nov 18, 2012 8:11 am

Very cool, thanks! :)

Post Reply