Error on Linux

2D audio barcode reader
Post Reply
rainydayshirts
Posts: 32
Joined: Tue May 12, 2015 11:31 pm
Location: Ferguson, Missouri, USA
Contact:

Error on Linux

Post by rainydayshirts » Thu May 14, 2015 7:18 am

I'm dying to use Phonopaper in addition to all of the other awesome software NightRadio producers. Unfortunately, I get an error anytime I try to start it on my Linux NetBook.

root# ./START_LINUX_X86
Language: en_US.UTF-8
SunDog Engine / Feb 10 2015 11:50:20
MAIN: device start
OpenGL version: 1.4 Mesa 10.1.3. Renderer: Mesa DRI Intel(R) 945GME x86/MMX/SSE2. GLSL: 1.20.
OpenGL error 0 in glCompileShader()
Shader 4 log:
0:25(2): error: syntax error, unexpected ';'

Error in device_start() 1
MEMORY CLEANUP (DYNAMIC)
FREE 592 gl_make_shader
Max memory used: 2452
Not freed: 592


Any ideas whats going on here? Is there something wrong with my OpenGL?
Jesse R. Schilling | rainydayshirts

| Bandcamp | Deviantart | Patreon |

User avatar
NightRadio
Site Admin
Posts: 3016
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Error on Linux

Post by NightRadio » Fri May 15, 2015 9:04 pm

Please try this version: http://warmplace.ru/soft/beta/phonopaper.zip
and send me the log again

rainydayshirts
Posts: 32
Joined: Tue May 12, 2015 11:31 pm
Location: Ferguson, Missouri, USA
Contact:

Re: Error on Linux

Post by rainydayshirts » Fri May 15, 2015 11:55 pm

Yay! That version appears to function. Well, it starts up and so far appears to be working. I'll play with it more and reply to this thread if I run into any problems. Thank you so much! I'm posting the log in case it helps you or I down the road. (The log is just what it spit out at me when I launched it. I haven't done much else with it yet.)

root# ./START_LINUX_X86
Language: en_US.UTF-8
SunDog Engine / May 15 2015 21:54:46
MAIN: device start
OpenGL version: 1.4 Mesa 10.1.3. Renderer: Mesa DRI Intel(R) 945GME x86/MMX/SSE2. GLSL: 1.20.
MAIN: screen_angle = 0
MAIN: screen_zoom = 1
MAIN: screen_ppi = 160
MAIN: screen_scale = 256 / 256
MAIN: screen_xsize = 640
MAIN: screen_ysize = 480
MAIN: system palette init
MAIN: wmanager initialized
ARCH: x86; OS: linux; LANG: en_US.UTF-8; CURRENT_PATH: ; USER_PATH: /root/; PIXILANG_VERSION: 03060000
Engine Working Directory (1:/) : /root/Downloads/phonopaper.zip_extracted/phonopaper/
Loading font 0
Initial font char size: 24 x 32
Final font char size: 12 x 16
Loading font 1
Initial font char size: 24 x 32
Final font char size: 12 x 16
New PWM container 589 created
Desktop window created
ANS engine test results: 27648.000000 samples per second
ANS Sampling rate: 27630
First generator: 14
Audio buffer size: 2048 frames
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

ALSA ERROR: Can't open audio device pulse: Connection refused
ALSA: default
ALSA HW Default rate: 44100
ALSA HW Rate: 44100 frames
ALSA HW Buffer size: 3763 frames
ALSA HW Period size: 940
ALSA HW Periods: 0
ALSA SW Avail min: 940
ALSA SW Start threshold: 1
ALSA SW Stop threshold: 3763
New ANS container 604 created
Back to the Live mode...
First generator: 20
ANS project:
width: 2
height: 600
lowest freq: 65.406250
octaves: 8
freq spread: 50.000000
BPM: 125
PPB: 16
Trying to open video device /dev/video0 ...
driver: uvcvideo
card: Integrated Webcam
bus_info: usb-0000:00:1d.7-2
version: 3.14.20
capabilities: 0x84000001
device_bvideo_open() successful
Got the camera size
Default camera frame size: 640 x 480
bvideo_get_props() error -1
New PhonoPaper container 599 created
bvideo_start(): 640x480; pixel format:0; focus mode:0
PhonoPaper Main Window created
ALSA snd_pcm_writei error: Broken pipe
ALSA EPIPE (underrun)
ALSA snd_pcm_writei error: Broken pipe
ALSA EPIPE (underrun)
ALSA snd_pcm_writei error: Broken pipe
ALSA EPIPE (underrun)
ALSA snd_pcm_writei error: Broken pipe
ALSA EPIPE (underrun)
Last edited by rainydayshirts on Sat May 16, 2015 12:10 am, edited 1 time in total.
Jesse R. Schilling | rainydayshirts

| Bandcamp | Deviantart | Patreon |

rainydayshirts
Posts: 32
Joined: Tue May 12, 2015 11:31 pm
Location: Ferguson, Missouri, USA
Contact:

Re: Error on Linux

Post by rainydayshirts » Sat May 16, 2015 12:03 am

Alright, I should have taken a second to goof around. Opened it up again, switched all the settings to what I use in all of the other WarmPlace apps (basically just switch to SDL and drop the Quality down to 5-25% depending on circumstance) and the only thing its giving me now is the underrun warning, which is expected. I'm running Pupp Linux (tahrPup) on a 5-6 year old Dell Inspiron Mini netbook. So that last log can propably be ignored. Again, I thank you so very, very much. both for your help with this particualr problem, and your ongoing contributions to the Artistic Community.

root# ./START_LINUX_X86
Language: en_US.UTF-8
SunDog Engine / May 15 2015 21:54:46
MAIN: device start
OpenGL version: 1.4 Mesa 10.1.3. Renderer: Mesa DRI Intel(R) 945GME x86/MMX/SSE2. GLSL: 1.20.
MAIN: screen_angle = 0
MAIN: screen_zoom = 1
MAIN: screen_ppi = 160
MAIN: screen_scale = 256 / 256
MAIN: screen_xsize = 800
MAIN: screen_ysize = 500
MAIN: system palette init
MAIN: wmanager initialized
ARCH: x86; OS: linux; LANG: en_US.UTF-8; CURRENT_PATH: ; USER_PATH: /root/; PIXILANG_VERSION: 03060000
Engine Working Directory (1:/) : /root/Downloads/phonopaper.zip_extracted/phonopaper/
Loading font 0
Initial font char size: 24 x 32
Final font char size: 12 x 16
Loading font 1
Initial font char size: 24 x 32
Final font char size: 12 x 16
New PWM container 589 created
Desktop window created
ANS Sampling rate: 11520
First generator: 79
Audio buffer size: 2048 frames
New ANS container 604 created
Back to the Live mode...
First generator: 115
ANS project:
width: 2
height: 600
lowest freq: 65.406250
octaves: 8
freq spread: 50.000000
BPM: 125
PPB: 16
Trying to open video device /dev/video0 ...
driver: uvcvideo
card: Integrated Webcam
bus_info: usb-0000:00:1d.7-2
version: 3.14.20
capabilities: 0x84000001
device_bvideo_open() successful
Got the camera size
Default camera frame size: 640 x 480
bvideo_get_props() error -1
New PhonoPaper container 599 created
bvideo_start(): 640x480; pixel format:0; focus mode:0
PhonoPaper Main Window created
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
Jesse R. Schilling | rainydayshirts

| Bandcamp | Deviantart | Patreon |

User avatar
xaccrocheur
Posts: 77
Joined: Sat Feb 27, 2010 3:16 pm
Location: Africa
Contact:

Re: Error on Linux

Post by xaccrocheur » Fri May 29, 2015 11:35 pm

I got this problem too (on Linux xxx 3.13.0-53-lowlatency #89-Ubuntu SMP PREEMPT Wed May 20 10:51:52 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux with an intel GMA 5000 - Pixilang, Sunvox and Virtual ANS run fine)

I tried the beta but still :

⚡ ./START_LINUX_X86_64
Language: en_GB.UTF-8
SunDog Engine / Feb 10 2015 11:49:45
MAIN: device start
OpenGL version: 3.0 Mesa 10.1.3. Renderer: Mesa DRI Intel(R) Haswell Mobile . GLSL: 1.30.
OpenGL error 0 in glCompileShader()
Shader 4 log:
0:25(2): error: syntax error, unexpected ';'

Error in device_start() 1
MEMORY CLEANUP (DYNAMIC)
FREE 592 gl_make_shader
Max memory used: 2590
Not freed: 592
Yassin Philip - Check out My music =@

User avatar
NightRadio
Site Admin
Posts: 3016
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

Re: Error on Linux

Post by NightRadio » Sat May 30, 2015 12:15 pm

I tried the beta but still :
Beta is May 15, but i see Feb 10 in your log - it is still the old one. Please make sure that you use the correct version from the latest beta.

Post Reply