JACK MIDI [FIXED 30.12.2015]

Found a bug? Post it here.
Post Reply
User avatar
NightRadio
Site Admin
Posts: 3008
Joined: Fri Jan 23, 2004 12:28 am
Location: Ekaterinburg. Russia
Contact:

JACK MIDI [FIXED 30.12.2015]

Post by NightRadio » Tue Jan 07, 2014 6:55 pm

description from Fuxoft:
I currently switched to using Jack audio and I now have a small problem with this latest SunVox version: Whenever I load song, the MIDI input gets disconnected, I have to open qjackctl connections window, enter the MIDI tab and connect "a2j_bridge" to "SunVox" again. It gets disconnected each time I load song into SunVox (without closing SunVox).

User avatar
cube48
Posts: 91
Joined: Tue Jun 21, 2011 10:33 am

Re: JACK MIDI

Post by cube48 » Tue Jun 30, 2015 12:39 pm

Confirming that happens to me too with 1.8.1 and higher. It seems that loading a song/project re-initializes MIDI connection from scratch. Like if SunVox is restarted.

allkhor
Posts: 1
Joined: Fri Oct 09, 2015 6:44 pm

Re: JACK MIDI

Post by allkhor » Fri Oct 09, 2015 6:56 pm

[RU] Доброго времени суток.
При редактировании модулей в MetaModule также происходит разрыв midi соединения.
Этот маленький баг очень сильно раздражает, приходится постоянно соединять a2j_bridge с SunVox.
Ubuntu 14.04 x86_64, Driver Jack, SunVox 1.9b
Спасибо за прекрасную программу!

User avatar
cube48
Posts: 91
Joined: Tue Jun 21, 2011 10:33 am

Re: JACK MIDI

Post by cube48 » Sat Dec 19, 2015 4:07 pm

Just found a workaround for this issue! You'll need qJackCtl installed but you might achieve the same results with other patch management utilities as well.

To get the lost JACK MIDI connection back and keep it automatically reconnecting you have to:

1. open qJackCtl and start jackd if it's not already running (starting the daemon is maybe optional)
2. open Connections and set your desired connections on MIDI and ALSA tabs - SunVox should be running at this time
3. open Patchbay and click to New button in the left top corner, confirm Yes that you want to create a new patchbay definition as a snapshot of all actual client connections, give some name to your snapshot
4. select your newly created snapshot from the drop-down bar (if it's not already selected)
5. click on Activate button in the top right corner of Patchbay window
6. go to Setup from qJackCtl window and check that in the Options tab there is your patchbay snapshot file in the Connections area with Activate Patchbay persistence activated if you want to get this setting loaded next time

Patchbay automatically reconnects the inputs and outputs of the activated snapshot as soon as all required clients are available again.

I still have to test this more thoroughly but so far it seems to be solving the issue with dropped MIDI connections of SunVox when loading arrangements/songs.

transient
Posts: 36
Joined: Thu Jan 05, 2012 8:17 am

Re: JACK MIDI [FIXED 30.12.2015]

Post by transient » Sat May 27, 2017 10:16 pm

cube48 wrote:Just found a workaround for this issue! You'll need qJackCtl installed but you might achieve the same results with other patch management utilities as well.

To get the lost JACK MIDI connection back and keep it automatically reconnecting you have to:

1. open qJackCtl and start jackd if it's not already running (starting the daemon is maybe optional)
2. open Connections and set your desired connections on MIDI and ALSA tabs - SunVox should be running at this time
3. open Patchbay and click to New button in the left top corner, confirm Yes that you want to create a new patchbay definition as a snapshot of all actual client connections, give some name to your snapshot
4. select your newly created snapshot from the drop-down bar (if it's not already selected)
5. click on Activate button in the top right corner of Patchbay window
6. go to Setup from qJackCtl window and check that in the Options tab there is your patchbay snapshot file in the Connections area with Activate Patchbay persistence activated if you want to get this setting loaded next time

Patchbay automatically reconnects the inputs and outputs of the activated snapshot as soon as all required clients are available again.

I still have to test this more thoroughly but so far it seems to be solving the issue with dropped MIDI connections of SunVox when loading arrangements/songs.
THANKS THANKS THANKS cube48! helped me out quite a bit :)

Post Reply